1

I am using ArcGIS Desktop version 10.7.0.10450

I have previously used Con statements in the Raster Calculator that now do not seem to work. I did hundreds of these with raster data about five years ago and have come back to updated the project but cannot figure out what has changed. The basics are a simple if/then statement:

new_raster=(Con(("raster1" - 100) < 0, 0, ("raster1"  -  100))) * 31

The result would be 0 if raster1-100 is less than zero or raster1-100. The multiplier at the end is a constant and could be done outside this statement if needed.

When I run the raster calculator it completes quickly, shows the following results, but there is no output raster and no error message.

What am I missing here?

enter image description here

  • Set environment extent, cell size to ones of raster. Con(raster<100, 0, raster-100)*31 – FelixIP Mar 18 at 19:58
  • Thanks FelixP ... the environment and cell sizes are set, but the result is the same. Nothing I do generates a result when this ran without a hiccup previously. – Cascade Environmental Mar 18 at 20:31
  • Try output to raster grid stored in folder. Databases sometimes do crazy things to raster. – FelixIP Mar 18 at 20:50
  • After two reboots of the software and one reboot of the computer it worked! Thanks for your help! – Cascade Environmental Mar 18 at 21:32
  • I noticed the statement in your OP "... it completes quickly, ... but there is no output..." I started noticing the same thing circa 10.6 or 10.7, both Arcmap and ArcCatalog. If I run a tool and it completes quickly w/o results I know that Arc is hosed, and the only solution is to power cycle the computer. Go figure... – Stu Smith Mar 19 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.