1

I'm using a Postgres database (with a PostGIS extension) connection in Geoserver to add new layers. When I add a new layer from this connection, in the Coordinate Reference Systems Section, Geoserver cannot identify correct SRS and the Declared SRS in EPSG:404000.

This error appears with most of my layers. Every layer has the same EPSG 4326 and I can confirm it by opening them in QGIS or consult it via query in PgAdmin. At first, I thought that the difference was the import tool: some were imported to the Postgres database using QGIS and worked, while the others, using the PostGIS Shapefile Importer, didn't. Later on, I tried to import the error layers using QGIS, but when I added them as a new layer in Geoserver, I still got the same error: Declared SRS in EPSG:404000.

What am I doing wrong? Is this a problem with the configuration of Geoserver, Postgis or the Shapefile SRS data?

Postgres Database is in Azure.

  • 1
    what does the geometry_columns view say about the layers that don't work? – Ian Turton Mar 19 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.