1

I've researched many similar threads but could not find the right answer for me.

I want to install APT version of QGIS 3.10 on Linux Mint 19.2 Cinnamon. I've successfully added repository and made it signed according to official QGIS installers page

afterwards apt install qgis qgis-plugin-grass throws in:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 qgis : Depends: python3-qgis (= 1:3.12.0+28bionic) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This happens after I tried:

apt autoclean
apt autoremove
sudo apt-get -f install

The problem persists. Any help will be much appreciated!


UPDATE

Okay the problem was likely in some corrupted packages from previous QGIS installation. I resolved the problem with aptitude: sudo aptitude install qgis qgis-plugin-grass

It first destroyed some of these packages, suprisingly then ran it the second time and QGIS 3.10 was installed seemingly without problems.

1

You are trying to install QGIS 3.12 which is currently not installable on bionic due to missing ubuntugis packages.

Take the ltr version without ubuntugis for the meantime.

And use apt install qgis python3-qgis to make sure python3 support is selected to be installed.

| improve this answer | |
  • Thanks, however, the same problem persists at version 3.10.4 as well. – Honza Chytrý Mar 21 at 20:06
  • What error message do you get with apt install python3-qgis? – AndreJ Mar 21 at 20:14
  • It is similar to what I get with apt install qgis : The following packages have unmet dependencies. python3-qgis : Depends: python3-qgis-common (= 1:3.10.4+28bionic) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Honza Chytrý Mar 21 at 20:17
  • I solved the problem with aptitude, see original question. Thanks again though! – Honza Chytrý Mar 21 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.