0

I made two tools using Model Builder on ArcMap 10.7.

I saved both toolbox as version 10.0 and tested on my ArcMap 10.7, they worked fine. I shared it with the public and it worked fine on ArcMap version 10.7. But the tool had a red X on it when people tried to use it on ArcMap 10.3.

I imagine this problem happens because some of the tools I used inside my tool had been updated on newer version of ArcMap.

Is there a way to fix it?

2

There are possibly two things going wrong here.

1) Make sure the tools you've used inside the Model exist at 10.3 and have the EXACT SAME PARAMETERS as they do in 10.7 vs 10.3. You'll need to use the different versions of the help to confirm this. (You can toggle the versions at the top). If they match (ie 10.7 does not have a new or updated parameter) you should be good. If they don't match, I'm not 100% certain that the down-save will fix the tools to the older version. If you determine this is the problem, you'll need to "fix" them in 10.3 and save them from that version.

2) After you do the simple Save-As and select the older version: DO NOT TOUCH the TBX with ArcMap 10.7 again. IE. Do not "Test" to see that it works. Depending on how you're "Testing" you might actually be upgrading the TBX back to 10.7. Simply save it, and don't use the new version again - test it with the old version.

5
  • So if I understood your answer correctly, I need to have both ArcMap 10.7 and ArcMap 10.3 in my computer to fix it. Right? I definitely did 2 wrong, but I dont think this is the problem, because when you have the TBX on 10.7, it simply doesn't show any tool inside on ArcMap 10.3, but what happenning here is that, it shows the tool inside but it is corrupted (shows a red X) Mar 23 '20 at 19:22
  • You can't have 10.3 and 10.7 on the same machine.The red-x means the model is "invalid". If you open it up on 10.3 and see the red-x, do an edit in modelbuilder and save it. Nothing else but save. This should "fix" it. If it does, I suspect it might be problem 1)
    – KHibma
    Mar 23 '20 at 23:06
  • It didnt worked it. Just got a responde from ESRI support, if I understood correctly, they said the Python on ArcGIS has changed in the most recent versions, so my tool will only work on ArcMap 10.5.1 or more recent versions. If I want to make it work on ArcMap 10.3, for example I would need to redo the whole thing using ArcMap 10.3. Mar 31 '20 at 14:32
  • What exactly is inside your tool that doesn't like the Python between 10.3 and 10.7??? Per this: support.esri.com/en/technical-article/000013224 You're talking about Python 2.7.15 vs 2.7.8. Unless you mean the tool you're making use of was NEW at 10.5.1, thus doesnt exist in 10.3. Or maybe a new Python module the tool uses was bundled at 10.5.1 and wasnt there previously.
    – KHibma
    Mar 31 '20 at 14:43
  • I don't know. ESRI support told me the problem was related to the following error: support.esri.com/en/technical-article/000011742 Mar 31 '20 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.