1

The situation is this:

Text Text Text Text

I need to remove the lines inside the blue polygon, I have tried with dissolve and delete holes processing tools but they didn't work. I would like to know if there is a solution. File: https://drive.google.com/file/d/1itv2Gpr4fPN6TpeSKJDRCZEox0hnFP76/view?usp=sharing

  • 3
    Dissolve should work. Could there be a very small gap which is not visible? Try "Snap points to grid" then Dissolve. – BERA Mar 23 at 19:27
  • If it is just for display purposes, set the border color to be the same as the inside color – JGH Mar 23 at 19:48
  • You have the source data with the wrong geometry, so one way: 1) Select on the panel: Analysis tools->Vector geometry->Correct geometries; 2) Then select the polygon you are interested in ->Vector->Geo-processing->Connection by... select the checkbox - "Only selected objects" ->Click on the button "Run" and that's it... – Cyril Mikhalchenko Mar 24 at 15:14
3

As BERA said, dissolve is the tool. The trick is in create a field with values equals for each contiguous feature to dissolve. So, I digitizing, approximately, your shapefile and it looks as follows:

enter image description here

If I want to dissolve all features, I have to create a field (e.g. common) with the same values in each record. Following image presents result of Dissolve (selecting field common) and, the attributes table corresponds to original layer (polygon_test). All features were dissolved as expected.

enter image description here

Now, I want to dissolve only contiguous features observed in following image. Field named commond2 must be selected in this case.

enter image description here

Result of running dissolve tool (deselecting all features selected previously) is as expected:

enter image description here

Editing Note:

With your shapefile, blue polygon above considered was selected in following image with QGIS. It is a Multipart feature.

enter image description here

So, run 'Multipart to singlepart' processing tool with default values. Result is visualized in below image. Additional created features have same id (82267) as original parent feature. So, id field is the one to be used in Dissolve tool.

enter image description here

Afterward Dissolve, in following image can be observed "fusion" of features as expected.

enter image description here

| improve this answer | |
  • The fact is that in my case It doesn't work, because there aren't different polygons but it's only a unique polygon, infact if I try to select a part everything will be selected as you cans see in my second image, so If I use dissolve nothing changes; if you want I can send you the shapefile so you will see – Matteo Pigliapoco Mar 23 at 23:29
  • Ok. Edit your question and put the Dropbox or Google Drive link in it. – xunilk Mar 23 at 23:34
  • ok, I have just put the link – Matteo Pigliapoco Mar 23 at 23:41
  • Please, see complete process in my Editing Note. – xunilk Mar 24 at 2:57
  • when I run multipart to single part this window pops up and even if i fill the parameters nothing starts i.gyazo.com/7934c8f141eb1f7a2555531398bb2443.png – Matteo Pigliapoco Mar 24 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.