1

I'm doing a QGIS course at the moment using QGIS 3.10 on a Windows 10 Pro 64bit system at the moment.

Settings are default, except for the "filter invalid geometries" option is set to "ignore".

With a shape selected and editing+vertex tool active, I can select a single vertex (shift+click) and edit or delete it. I can also select all vertices on a line by pressing shift+r and then selecting the first and last vertex.

I cannot, however, select multiple vertices by dragging a box. I have tried for 2 hours now, and I just don't get why it doesn't work. Has anyone else seen this problem with QGIS 3.10, and has anyone solved it?

  • I have the exact same issue as OP describes. I have the layer selected, in edit mode, using the vertex tool, and when I click and drag a box over one or multiple vertices, nothing happens. It's as if I never clicked and dragged the box in the first place. I really hope there is a solution for this. I'm just adding this to let you know that there are more people who experience the same problem. – Martin Nilsson Apr 1 at 11:38
  • Did installing the newer stable version do the trick for you? – Moritz Apr 1 at 16:11
2

I don't see any issue with selecting multiple vertices by dragging a box to do selection. It works as expected:

enter image description here

I used the Delete button to delete the selected vertices.

Try after using shift+r or shift+click to click any place outside, at the white background, to remove the selection. Also press the Esc button on your keyboard to remove any effects of the shift+r or shift+click. It may solve the problem.

|improve this answer|||||
  • Hello Ahmadhanb, this is how I would expect it to work. I reinstalled QGIS once more (I did that once before to no avail). This time, I replaces QGIS 3.10.3-3 with version 3.10.4-1. Vertex tool now works as shown in your video. Thanks for your feedback, anyway. – Moritz Mar 26 at 10:00
  • @Moritz Glad the problem is solved. :) – ahmadhanb Mar 26 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.