0

I installed GRASS GIS following the tutorial on the website for the Ubuntu 18.04 version. However, the Temporal Plot Tool function is not working, and is giving an error related to python.

Below is the error that is giving in the tool.

Unable to start Temporal Plot Tool

Motivo: The Temporal Plot Tool needs the "Matplotlib" (python-matploltib) package to be installed. Cannot load backend 'WXAgg' which requires the 'wx' interactive framework, as 'gtk3' is currently running

Traceback (most recent call last)
File "/usr/local/grass78/gui/wxpython/tplot/frame.py", line 36, in <module>
matplolib.use('WXAgg')
File "/home/luiz/.local/lib/python3.6/site-packages/matplotlib/cbook/deprecation.py", line 296, in wrapper
return func(*args, **kwargs)
File "/home/luiz/.local/lib/python3.6/site-packages/matplotlib/cbook/deprecation.py", line 358, in wrapper
return func(*args, **kwargs)
File "/home/luiz/.local/lib/python3.6/site-packages/matplotlib/_init_.py", line 1281 in use 
plt.switch_backend(name)
File "/home/luiz/.local/lib/python3.6/site-packages/matplotlib/pyplot.py", line 237, in switch_backend
newbackend, required_framework, current_framework))
ImportError:Cannot load backend 'WXAgg' which requires the 'wx' interactive framework, as 'gtk3' is currently running

During handling odf the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/local/grass78/gui/wxpython/lmgr/frame.py", line 1930, in OnTplotTool
from tplot.frame import TplotFrame
File "/usr/local/grass78/gui/wxpython/tplot/frame.py", line 45, in 
<module>
'(python-matplotlib) package to be installed. {0}').format(e))
ImportError: The Temporal Plot Tool needs the "matplotlib" (python-matplotlib) package to be installed Cannot load backend 'WXAgg' which requires the 'wx' interactive framework, as 'gtk3' is currently running

What should I do to solve this problem?

9
  • Did you follow these instructions? grasswiki.osgeo.org/wiki/… (we have numerous Ubuntu installations running and did not encounter this problem)
    – markusN
    Mar 26, 2020 at 7:55
  • hello, thanks for replying. so, I followed the instructions line by line, and I had this problem. I reinstalled the grass and again followed with the same error.
    – Santos
    Mar 26, 2020 at 13:26
  • Please open a bugreport here: github.com/OSGeo/grass/issues . Also include besides the message above also the output of g.version -rge to know the detailed library versions. Thanks
    – markusN
    Mar 27, 2020 at 11:29
  • ... if needed, I can do that for you. But please post the error as text, not as PNG (otherwise I cannot copy over the error message)
    – markusN
    Apr 2, 2020 at 9:33
  • Hi markusN, I did what you asked
    – Santos
    Apr 4, 2020 at 14:38

1 Answer 1

0

As per issue (https://github.com/OSGeo/grass/issues/489#issuecomment-609455498) here the solution:

apt install python3-matplotlib

The installation of the matplot library solved the reported with the Temporal Plot Tool on Ubuntu.

1
  • FYI: On Fedora (maybe others), additionally python-matplotlib-wx must be installed.
    – markusN
    Jul 25, 2020 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.