2

So I'm having a problem in QGIS 3.12 where the text for certain buttons, menu items and messages is improperly spaced/positioned within the UI, and in many cases, is totally hidden from view. Additionally, in many parts of the UI the scroll bars are tiny, to the point where they can't be used, most irritatingly when viewing attribute tables.

These issues are making QGIS borderline unusable for what I need to do.

I believe part of the cause has to do with the fact that I changed the aspect ratio of my computer as I recently reconfigured my display setup with a second monitor. However multiple resets of the aspect ratio settings has been of no avail and neither has a reinstall of QGIS.

No other software on my computer has this issue.

My question: How can I fix my text and UI problems with QGIS?

Edit: Here is an example of how some of the text looks like. Note that there are entries in this list that aren't visible.

Edit 2: So it turns out that resetting the computer itself was what was required. I did change the settings as per the comment below and reset but I don't know if the changes were required.

If you encounter this problem yourself, first try just resetting your computer, and if that doesn't work, try changing the settings as below.

enter image description here

9
  • Have you tried: Find the qgis executable. If installed with OSGeo installer, it is in C:\OSGeo4W64\bin. Right click on qgis-bin.exe and choose Properties. Select the 'Compatibility' tab (the second tab). Select 'Change high DPI settings' at the bottom of the tab. Check 'Override high DPI scaling behavior' at the bottom. Select 'System (Enhanced)' from the drop down.
    – Kartograaf
    Mar 30 '20 at 23:46
  • Hi @Kartograaf I tried that but it didn't fix the issue. Thanks for your suggestion. Apr 1 '20 at 6:52
  • It looks like you use different UI theme. Did you try to change UI Theme option as default in "Settings > Options > General > UI Theme" Apr 3 '20 at 8:35
  • Does right click menu look like that? Apr 3 '20 at 12:26
  • Does by chance the software behave properly on the original screen when this original screen and only this screen is on? And what are your screen resolutions? Apr 5 '20 at 20:38
1

So it seems my problem was resolved by resetting my computer.

If you run into this problem yourself and resetting alone doesn't solve the problem, I recommend taking the following steps (thanks @Kartograaf) and then resetting the computer again:

"Find the qgis executable. If installed with OSGeo installer, it is in C:\OSGeo4W64\bin. Right click on qgis-bin.exe and choose Properties. Select the 'Compatibility' tab (the second tab). Select 'Change high DPI settings' at the bottom of the tab. Check 'Override high DPI scaling behavior' at the bottom. Select 'System (Enhanced)' from the drop down".

That should resolve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.