1

I am using QGIS in order to delineate a watershed, and am using 1/3 arcsecond DEMs. I have created a Filled DEM using the SAGA Fill Sinks xxl (Wang & Liu) tool. Next I ran the SAGA Channels and Drainage Basins tool, where the Channels were the only useful result. From here, using the Coordinate Capture plugin I was able to exact a coordinate point on the most downstream part of the channel (or river in this case) that I am trying to create the watershed of.

From here, I ran the SAGA Upslope Area tool using the Filled DEM raster and the (x,y) coordinate I just captured. The resulting layer that I created, however, was all black and the histogram distribution is min=0 and max=0. Why does this Upslope Area Layer not give me a result in which the min = 0 and the max = 100 and the resulting layer shows me the Upslope portion above that point in white and everything else in black?

What would the sources of my problems be? How do I fix them?

1

The SAGA Upslope Area tool has worked for you correctly, though you would be seeing the black output layer (Upslope Area), plus Min=0 and Max=0 statistics in its Symbology panel.

Change the Max setting from zero to a small number (< 1.0), like 0.2 in my example (below).

enter image description here

You will find a blob around the point you have given as the outlet coordinates. That is your Upslope Area. Please check the cell values by the Identify tool and adjust the max value accordingly.

enter image description here

3
  • First, thanks for you response. So I have styled the Upslope Layer accordingly, but it is still coming up a blank screen - with whatever color value is associated with zero. Even when I change the max to something like 0.2, nothing changes. I used the Raster Information tool and found out the min=0 and max=100. When I change the max to 100, still nothing changes. – Colter Birk Mar 31 '20 at 20:45
  • I don't know exactly what you mean when you say check the cell values with the Identify tool, but I think I got the correct min and max with the Raster Layer Information tool. – Colter Birk Mar 31 '20 at 20:49
  • @ColterBirk I meant to check the cell value of the blob, but you won't be able to do so if you could not find it. I have to wonder which cell gave you max=100 in your raster. Can you post the output of the raster information tool? – Kazuhito Mar 31 '20 at 23:12
1

What finally worked for me was zooming in and capturing the coordinates of a point precisely in a channel. Points near but not in a channel had given me upslope areas too small to see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.