1

I have imported a shapefile containing land use data for the UK. The layer says that its' coordinate system is EPSG:2770 OSGB 1936, however, when I display the image over a basemap it becomes obvious that the shapefile CRS is using WGS 84.

The first image is when the basemap CRS is set to EPSG:3857 and shapefile CRS is OSGB 1936. The second image when the basemap CRS is set to OSGB 1936 and shapefile CRS is OSGB 1936.

image when the basemap CRS is set to WGS 84 and shapefile CRS is OSGB 1936

image when the basemap CRS is set to OSGB 1936 and shapefile CRS is OSGB 1936

Here is the metadata for the shapefile:

General

Storage type of this layer ESRI Shapefile

Description of this provider OGR data provider (compiled against GDAL/OGR library version 2.4.0, running against GDAL/OGR library version 2.4.0)

Source for this layer C:/Users/OneDrive/Ecology/CRS/1_q3/LCM.shp

Geometry type of the features in this layer Polygon (WKB type: "Polygon")

The number of features in this layer 6737558

Capabilities of this layer Add Features, Delete Features, Change, Attribute Values, Add Attributes, Delete Attributes, Rename, Attributes, Create Spatial Index, Create Attribute Indexes, Fast, Access to Features at ID, Change Geometries

Extents In layer spatial reference system units xMin,yMin 54236.5,5333.81 : xMax,yMax 655649.84,1220310.00

Layer Spatial Reference System +proj=tmerc +lat_0=49 +lon_0=-2 +k=0.9996012717 +x_0=400000 +y_0=-100000 +ellps=airy +towgs84=446.448,-125.157,542.06,0.15,0.247,0.842,-20.489 +units=m +no_defs

Is there anyway I can fix this? I have tried a variety of transformations in both QGIS 2 and 3.

EDIT: Problem fixed by using the 'Reproject Layer' tool to reproject the shapefile to WGS 84

3
  • Have you enabled on the fly reprojection for the older QGIS version?
    – Erik
    Apr 1 '20 at 13:21
  • Google base maps are always in 3857 so you can't reproject them on the fly to OSGB, so you shapefile is correct and will be reprojected to 3857 to align it with the base map - the 1st image is correct
    – Ian Turton
    Apr 1 '20 at 14:00
  • There is a mixture of problems, but the shapefile is not being reprojected as WGS84 (when that happens, the degrees are interpreted as meters and a country only measures a few meters). Maybe you have a problem to reproject the basemap to EPSG:27700 in QGIS3, but surely you can't reproject the basemap to EPSG:27700 in QGIS2. Please, edit your question to include what plugin are you using to render the basemap and what QGIS version are you using for each screenshot. Apr 1 '20 at 15:22
3

If the source co-ordinate reference system (under layer properties > source) is set to OSBG, it sounds as if the shapefile geometry is in wgs84 co-ordinates despite what the metadata is claiming.

If that's the case, then set project CRS as per the first screenshot and use 'Reproject Layer' from the toolbox and then save the output from that.

2
  • This is exactly what I was after and worked perfectly. Thanks! Apr 2 '20 at 9:08
  • @BulletTooth If the answer has worked for your problem, please select it as correct using the green tick mark next to the question. Apr 2 '20 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.