0

I'm encountering a strange problem: I cannot execute any tools in QGIS (e.g., buffer, join--literally everything anything in the Vector or Raster menus. This seems to apply to all tools in all plug-ins, including the QGIS tools, GDAL, Grass, and Saga. I can see the tool options, but clicking one (e.g., Vector > Geoprocessing Tools > Buffer) deselects QGIS. It looks as if another window is opening but I am unable to see it or interact with it.

This error is happening 3.10.4, but also occurred in version 3.8 and 3.12. I have uninstalled and re-installed QGIS numerous times, and have deleted all leftover files in Program Files in between installs. The last build where QGIS worked as normal was version 3.8.

Any ideas?

  • Hi Pat K, welcome to SE-GIS! I don't have a definitive answer, so I'll only offer a comment. Perhaps your personal QGIS profile has been corrupted (altered? modified?), so that no matter which version of QGIS is installed, it always looks to your profile, and... well, there you go. That profile used to be located in c:\users\yourname\.qgis2 I don't know if the "2" referred to QGIS version 2.x, and was supplanted by something else with the release of QGIS version 3.x. Try uninstalling QGIS, then clearing out anything QGIS-related in c:\users, then reinstall QGIS. Backup c:\users first! – Stu Smith Apr 3 at 20:58
  • 2
    You didn't happen to previously use a multi-monitor set up and now it's pushing the geoprocessing windows somewhere else? When the invisible geoprocessing window opens and deslects QGIS, can you press the Windows key + left arrow button a few times and see if it brings that window back to your main screen? – she_weeds Apr 4 at 2:17
  • you can try to start with a new profile: Settings->user profiles->new profile... if the the problem is solved in the new profile you can delete the default profile, just click on Settings->user profiles->open active user folder, which will lead you to the profile folder (in windows it is something like C:\Users\myusername\AppData\Roaming\QGIS\QGIS3\profiles and there you can either proceed like @Stu Smith proposed – eurojam Apr 4 at 4:50
1

@she_weeds was exactly right! My new monitor setup caused the geoprocessing window to be off on a different screen. Pressing Windows + the left button caused it to reappear.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.