1

I have two vector shapes, downloaded from government providers, that should be overlapping perfectly but one appears way of to the east of the other one. They are both set to the same CRS.

I work with several other layers too, which all fit perfectly with the first one. When I load in the second layer (the one that is off) it says "CRS was undefined". I then set it to the project CRS manually.

Any idea what I'm doing wrong here?

Matching Layers

Not matching Layer

8
  • 3
    Which GIS software do you use? Can you add some screenshot of your layers?
    – imre
    Apr 10 '20 at 11:07
  • 3
    are you sure you set it to the correct crs?
    – MrXsquared
    Apr 10 '20 at 11:24
  • 2
    the second data set is not in the projection you think it is
    – Ian Turton
    Apr 10 '20 at 12:27
  • sorry, I'm using QGIS 3.12 I checked the CRS settings over and over, they are set to the same CRS. What do you mean by its not the projection i think it is?
    – wubbe
    Apr 10 '20 at 14:30
  • If you have several layers displayed properly, and one layer which doesn't fit to them, then this one has wrong CRS settings. We could give you more specific answers if you could give us some more details about your problem. Which CRS is set to your layers? Some screenshots would be helpful too.
    – imre
    Apr 10 '20 at 15:32
3

If I set the shapefile "ffh-gebiete__flaechen_.shp" to EPSG 31468 (DHDN / 3-degree Gauss-Kruger zone 4), then it overlays correctly with the other layer. This means that the underlying coordinates of the shapefile weren't in UTM 32, but DHDN / 3-degree Gauss-Kruger zone 4.

Once you've set the correct crs, QGIS can handle on-the-fly reprojection, meaning that it can display your shapefiles in the crs of your project, even if the crs of the shapefile is not the same (provided that its crs was set correctly). Of course, you could also save your layer as UTM 32N, which would effectively recompute the coordinates in the shapefile to UTM 32N.

enter image description here

1
  • I think I get it :D Thank you very much for your help!
    – wubbe
    Apr 12 '20 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.