4

At 3.10.4 I tried to load a FGDB polygon feature class, but it failed, with an "Invalid Data Source" error. I tried the load with both the Vector > Directory > ESRI FileGDB and Vector > Directory > OpenFileGDB methods:

enter image description here

It turns out that the FGDB had been previously compressed using the Arc Desktop Compress File Geodatabase Data tool. Fortunately I have access to Arc Desktop and was able to uncompress the FGDB using the Uncompress File Geodatabase Data tool.

Following the uncompress, QGIS successfully loaded the feature class.

This experience leads me to believe that QGIS cannot load compressed FGDBs. An internet search did not turn up anything.

Note that I'm not asking about FGDBs that have been zipped.

I am now curious; are there any open-source tools that will uncompress a FGDB? Or allow QGIS to load a compressed FGDB feature class?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.