1

I am having an issue selecting a joined layer in the 'value' dropdown under graduated symbology to create a choropleth map. I joined originally the data from a csv file, but after I encountered this issue I redid it using the Add Delimited Text Layer option. I thought the issue could be occurring due to incorrect data type (string vs. numeric), so I used the to_real() function within the attribute table to change the data type of the particular attribute. I have referenced this post on the same subject. However, even after completing the change of data type, the attribute still does not show up as an option under graduated symbology. There is one NULL entry, could this have an effect? I am not sure what is going wrong. enter image description here enter image description here

  • 1
    Have you tried deleting the feature with the NULL attributes to see if the attribute appears in your graduated list? An other point is, the function to_int(NULL) will give you NULL, you'd need something like if("attribute" is NULL, 0, to_int("attribute") to transform NULL values into a 0. – LeoC Apr 14 at 20:35
  • Have you followed the instructions in the other post carefully, you don't need to change the datatype in the attribute table, you need to do it in the styling panel with expressions. You should not see sheet_target in the dropdown list, only to_int(sheet_target) (and only if it is the active field - if you change to something else it will disappear from the list). I have tried it with nulls in the data and it should not affect whether it appears in the list or not. – she_weeds Apr 16 at 7:08
  • I have updated the answer in that post with some screenshots to make it clearer, hopefully that helps? – she_weeds Apr 16 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.