0

The Code it occurs on each of the following interchangable lines that I have tried:

arcpy.Clip_analysis(dvof_input, feature_name, rwy_dvof_output_prefix + row['LOW_IDENT'] + rwy_dvof_output_suffix, "")
arcpy.Clip_analysis(dvof, feature_name, rwy_dvof_output_prefix + row['LOW_IDENT'] + rwy_dvof_output_suffix, "")

Note: The only difference between these two input features is one is that dvof is a clip of dvof_input occurring earlier in the script.

The Error:

ERROR 999999: Error executing function. The coordinates or measures are out of bounds. Failed to execute (Clip).

Will not work in Script, works fine when I use the Clip Tool. I even copy/pasted the exact Python Snippet from the Clip tool and put it into the Arcpy Script and the error persists.

It's even more confusing, because the same input feature clips to a different feature successfully earlier in the script (although it usually takes ~8 minutes):

arcpy.Clip_analysis(dvof_input, buffer, dvof, "")

I have another dataset of Points, similar to this dvof_input, called dof_input, which works just fine for both parts of this script:

arcpy.Clip_analysis(dof_input, buffer, dof, "")
...
arcpy.Clip_analysis(dof, feature_name, rwy_dof_output_prefix + row['LOW_IDENT'] + rwy_dof_output_suffix, "")

Worth noting, the "feature_name" polygon was created in ArcPy, and was projecting incorrectly until I added the SR to the creation of it:

## splay is a list of arcpy.Point objects ##
arcpy.CreateFeatureclass_management(arcpy.env.workspace, feature_name, "POLYGON",
                                        spatial_reference=arcpy.env.outputCoordinateSystem)
cursor = arcpy.da.InsertCursor(arcpy.env.workspace + '\\' + feature_name, ['SHAPE@'])
array = arcpy.Array(splay)
splay = arcpy.Polygon(array, arcpy.env.outputCoordinateSystem)
cursor.insertRow([splay])

Any other information I can add to diagnose this one? I tried to be comprehensive here so someone could spot a glaring issue.

  • Probably not the cause of your error but instead of arcpy.env.workspace + '\\' + feature_name do os.path.join(arcpy.env.workspace, feature_name) (and import os). This will save you from future path problems. – BERA Apr 15 at 14:59
  • 1
    How did you set arcpy.env.outputCoordinateSystem? There's a difference between Coordinate System and Spatial Reference in ArcGIS parlance (the latter has the rules for integerization that appear to be the issue). You should include all the Spatial Reference parameters involved, as well as the extents of the data layers. – Vince Apr 15 at 19:04
0

Figured this out... basically sometime between the first instance where the code worked, and the line where the error was thrown, I was using

arcpy.env.outputCoordinateSystem = sys_coord_input #(WGS_1984)

and then applying that to a Polygon I created in the script because it would not project properly without a reference to it. I removed that line of code, and instead, set the variable sr and replaced all calls to arcpy.env.outputCoordinateSystem with it

sr = arcpy.SpatialReference(4326)

This is still a concept that I haven't wrapped my head around yet.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.