0

I am using QGIS 2.18.28.

I am trying to convert a vector file into a raster using the rasterize tool however it us just producing a back block of a single value. I am rather confused as I have used this tool on another shapefile in the same project and it has worked perfectly.

The first screen shot is of the shape files in which i want to convert to raster (Nodes). I have included the attributes table in the screen shot.

The second screen shot is the input in which I used in the tool.

The the third screen shot is the output.

enter image description here

enter image description here

enter image description here

5
  • Please consider upgrading to the latest LTR.
    – Erik
    Apr 17, 2020 at 8:47
  • If you change the Raster type from float32 to integer, will it solve the problem?
    – ahmadhanb
    Apr 17, 2020 at 8:58
  • I have tried each of the raster type options and have produced the same output Apr 17, 2020 at 9:10
  • Hello - similar situation here. I have a raster of tree canopy (nlcd_2016...) and a vector of post 2016 HazFuels treatment areas. I'm trying to rasterize the latter into a grid of 1s (no treatment) and 0.45 (treatment) with the intent of multiplying the nlcd raster by the rasterized HazFuels treatment areas to crudely express the change in tree canopy since 2016. I've been hacking at this all day, and can't get anything better than a raster of a constant value or a raster of 0.45 and 'no data' . What works? link
    – G. Moore
    Dec 21, 2021 at 0:15
  • Try with smaller pixel size. What the result will be?
    – Nikos
    Nov 26, 2022 at 13:05

1 Answer 1

1

Had a similar issue.

changed burn-in value to 1 (it was set to 0) problem solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.