0

Trying to install GeoPandas using Anaconda for Python 2 (geopandas version in anaconda navigator is 0.6.1).

I also have ArcGIS 10.7 pre installed. First when I tried to install it through the navigator I got this message:

geopandas -> python[version='>=3.5|>=3.8,<3.9.0a0|>=3.7|>=3.6']

Your python: python=2.7

If python is on the left-most side of the chain, that's the version you've asked for. When python appears to the right, that indicates that the thing on the left is somehow not available for the python version you are constrained to. Note that conda will not change your python version to a different minor version unless you explicitly specify that.

Then tried to create a new env and declare I meant for Python 2 and not 3 use this commands which I saw in the offical GeoPandas page.

conda create -n geo_env

conda activate geo_env

conda config --env --add channels conda-forge

conda config --env --set channel_priority strict

conda install python=2 geopandas

When I ran those commands in the anaconda prompt I got this message in the picture below saying there is a package conflict between pandas to geopandas (tried also to uninstall all dependencies (shapely,pandas etc) from anaconda navigator and then run the commands again but got the same message in the picture below).

enter image description here

2
  • Please place error messages in the Question body as text, not an image. Text is legible on all devices and searchable so that others can find your question.
    – Vince
    Commented Apr 21, 2020 at 13:33
  • you need to specify the version of python when creating the env conda create -n geo_env python=2, then activate and install geopandas. Or, all at once, conda create -n geo_env geopandas python=2
    – rickD
    Commented Jun 15, 2020 at 19:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.