3

I am trying to install Fiona into a cloned conda environment in ArcGIS Pro. I have cloned the default environment and tried to install it both through ArcGIS and through the conda prompt (through default channel setup and specifying conda-forge). I have tried cloning an environment, removing everything except arcgis and arcgispro and then reinstalling gdal/fiona/geopandas.

Everything I try results in an ImportError (or worse):

>>> import fiona
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\ProgramData\Anaconda3\envs\dev_37\lib\site-packages\fiona\__init__.py", line 83, in <module>
    from fiona.collection import BytesCollection, Collection
  File "C:\ProgramData\Anaconda3\envs\dev_37\lib\site-packages\fiona\collection.py", line 9, in <module>
    from fiona.ogrext import Iterator, ItemsIterator, KeysIterator
ImportError: DLL load failed: The specified module could not be found.

I am experienced using conda outside of ArcGIS and have a few working conda environments for different purposes. However, I would like to have access to ArcPy and Fiona (really GeoPandas) in the same environment as I have one dataset that is very large and stored in a gdb and reading/writing with GeoPandas is way slower than with ArcPy, but I also have a large number of functions written in GeoPandas that I would prefer not to rewrite in ArcPy.

I believe the cause of the issue is that ArcGIS Pro uses a different (Esri) GDAL than you get from a typical install via anaconda or conda-forge:

gdal                      2.3.3               arcgispro_1  [arcgispro]  esri
1
  • How did you downgrade fiona? After uninstalling fiona in Add Packages there's only the option to install 1.8.11.
    – Atreyu
    May 25 '20 at 21:02
3

I just struggled through this. ArcGIS Pro (v2.5) doesn't seem to support all of the dependencies for fiona v1.8.6, even though that is the recommended install version. If you downgrade fiona to 1.8.4, all of the other dependent modules will subsequently downgrade. After the downgrade, everything imported fine for me.

0

Another way which worked for me was updating/installing fiona in the anaconda promt with

conda install -c conda-forge fiona

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.