2

I am trying to align two shapefiles (LA County freeways and LA County city boundaries) to see which freeways run in each city.

In QGIS, the shapefiles don't align. The freeway layer has a warning question mark saying "no CRS set for layer," however once I set the CRS to match the city boundaries layers (WGS 84 epsg:4326), nothing changes. I "save feature as" shapefile with the same CRS and the imported result is still misaligned with the boundaries.

I tried to export the file again, setting the extent to match the city boundaries, but then it just exports with 0 features.

How can I get the files to align? Specifically, how do I get a file with no CRS to align with another if simply setting the CRS and re-importing does not work?

1
  • 2
    Your freeway shields are in NAD_1983_StatePlane_California_V_FIPS_0405_Feet (ESRI:102245) which is mentioned in the source qgis.org/api/… but the boundaries are WGS84 Geographic (EPSG:4326) have a read of gis.stackexchange.com/questions/280871/… which might help, though I'm no expert in northern hemisphere coordinate systems to assay the efficacy of those posts. Apr 27, 2020 at 1:09

1 Answer 1

8

I downloaded both files and they worked fine for me by simply dragging and dropping the .shp components onto the map canvas with the project CRS set to EPSG:4326.

QGIS loaded the freeways layer in EPSG:2229 NAD83 / California zone 5 so if you need to manually set the CRS, set it to that - not EPSG:4326).

example

Double check that the .prj sidecar file is present in the same location as the rest of the files. If there is no .prj-file, you can either download the file again or remove the layer from your project, reload it and then manually set the layer CRS to EPSG:2229.

1
  • Thank you. Setting the CRS to EPSG:2229 NAD83 / California zone 5 worked. I assumed it was 4326, usually I get a message if it's not.
    – auto
    Apr 27, 2020 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.