6
ERROR 3: Free disk space available is 55518121984 bytes, whereas 69156878736 are at least necessary. You can disable this check by defining the CHECK_DISK_FREE_SPACE configuration option to FALSE.

I receive this error when trying to re project a .tif file on my EC2 instance. I understand that warping a file requires more memory than the size of the file itself. Is there any way to decrease the amount of memory required?

Here is my command:

gdalwarp --config GDAL_CACHEMAX 2048 -wm 512 -wo NUM_THREADS=ALL_CPUS -srcnodata nodata_masking_values -dstnodata 0 input_file.tif output_file.tif
4
  • 2
    Change the output cell size to a greater cell size (-te in output SRS units or -ts in rows and columns) or perform the warp in chunks by using a box shapefile cut into quads or 16ths with -te and allow a slight overlap then GDAL_Merge the results together. Considering your output is a GeoTIFF you could specify -of GTIFF -doo compress=deflate to use deflate compression in your output (likewise -doo compress=LZW is also a good choice, read more gdal.org/drivers/raster/gtiff.html) then the free space check should be less pessimistic in its estimation of the free space requirement. Apr 28, 2020 at 1:27
  • 3
    @MichaelStimson I recommend not using compression in gdalwarp, but warping to a VRT first, then running gdal_translate with compression.
    – user2856
    Apr 28, 2020 at 2:35
  • 1
    Can you please edit your question and include the output of gdalinfo input_file.tif
    – user2856
    Apr 28, 2020 at 2:36
  • 1
    Try adding CHECK_DISK_FREE_SPACE NO after the --config parameter. Mar 3, 2021 at 21:54

0

Browse other questions tagged or ask your own question.