0

enter image description here

I'm importing a CSV file into ArcGIS Pro, I've used geoprocessing tool XY Table to Point but values have come in null. Column type is double in ArcGIS Pro. Highlighted is the column which imports null from Excel.

enter image description here

  • Possibly the forbidden math expression in the field name ("-") – Vince Apr 28 at 18:53
1

I suspect that the formatting of the excel table might have something to do with it? Try changing the data type of that column within excel to a numeric type and the bring them back in. It would also be worth inspecting the data type in Arc-Pro by going to the field management. This can be done by opening the table and clicking add field, which will open a secondary table. If the data type is something like "text", then you have likely discovered that the formatting in excel is the issue at hand.


As stated in comments:

That worked! I changed the file type to .xlsx and then ran table to excel.

| improve this answer | |
  • Thank you for your response. Using the =ISNUMBER function in excel it returned all the entries in that field were numbers. I also checked the field type in ArcPro, the data type is Double and under the Number Format heading it is Numeric. – swadedun Apr 28 at 18:22
  • Out of curiosity, do the columns for long and lat import as double or float? – JamesS Apr 28 at 18:27
  • Both Lat and Long import as double. – swadedun Apr 28 at 18:36
  • Might try copying and pasting that column into a new column by doing a "Paste Values" in excel and then "Table to Excel" back into Pro. Could fix the issue... Have you tried doing the import more than once? Sometimes there is just an error in the import process. – JamesS Apr 28 at 18:43
  • 1
    That worked! I changed the file type to .xlsx and then ran table to excel. – swadedun Apr 28 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.