I have problems using the .clip utility from the GeoPandas package. I found in this post that the problem might be due to the GeoPandas version, since this utility is only available in > 0.7 version.


I tried conda install geopandas, but always I receave the notification that the version 0.6.1 will be installed, and not the version 0.7. Is there a way to do it through conda and not pip?

  • 2
    Install geopandas from conda-forge channel. conda install -c conda-forge geopandas. May 1 '20 at 8:11
  • Same problem. Created env in Anaconda Navigator, installed Spyder 4, conda installed Geopandas but said there were a lot of package conflicts. I'm stuck with 0.6.1. It seems like Geopandas 0.7.0 isn't compatible with any version of Spyder, at least in my situation.
    – BallpenMan
    May 9 '20 at 14:07
  • But @martinfleis' comment worked!
    – BallpenMan
    May 9 '20 at 14:15

GeoPandas development team does not have control over the version which comes from conda defaults channel, but it does have control over conda-forge channel. GeoPandas installed from conda-forge will be always the most recent release, unless there are some other dependency constraints.

If using conda, ideally install GeoPandas using conda install -c conda-forge geopandas instead of simple conda install geopandas.


I had the exact same problem.

Using the code below was the only way I was able to install Geopandas 0.7.0 using Python 3.7.7:

git clone https://github.com/geopandas/geopandas.git

cd geopandas

pip install .
  • This does not install 0.7.0 but the latest development version. Jun 20 '20 at 19:41

I've solved the problem using Anaconda Navigator.

  1. I've created one new environment
  2. i've install geopandas in conda's environment created at point 1 (the version was 0.6.1)
  3. In Anaconda Navigator in the environment I've select geopandas and upgrate to version 0.8.1 (the version available at the time of writing).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.