1

I'm just trying to add a delta symbol to label a feature for a shapefile in QGIS. I do this by typing the label in the appropriate cell during an editing session. I've tried copying and pasting Δ and it turns into a question mark for my label after saving the edits. I've also tried the ALT+30 method that produces the filled-in variety ▲. The same thing happens; it turns into a question mark after saving the edit. Thanks for your help.

2
  • 3
    Could be an issue of encoding. Please provide more details: what kind of layer do you use (Shepfile, Geopackage etc.). Try to export your layer and set encoding to UTF-8 and try again: does this help?
    – Babel
    Commented May 2, 2020 at 19:01
  • Great this worked! It was a shapefile by the way. I didn't even know you could set the character encoding in QGIS when you used the Save As option.
    – Mr. J
    Commented May 2, 2020 at 19:17

1 Answer 1

2

After @babel's comment:

Could be an issue of encoding. Please provide more details: what kind of layer do you use (Shepfile, Geopackage etc.). Try to export your layer and set encoding to UTF-8 and try again: does this help?

I used the Save As option for my shapefile and set the encoding to UTF-8. Then I just copied and pasted Δ in the cell and it remained after saving the edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.