0

I have tested with point and polygon layer. I get no terrain altitude binding. I use for the project and for the layer crs WGS 84 / UTM zone 32N (32632). Screenshot example with point layer, cylinder. I use SRTM1 data for the terrain. Also tested without success: altitude clamping absolute and relative.

What could I do better to get a correct result? Or is this a bug within QGIS?

QGIS 3.10.5, Windows 10 enter image description here

This is want I want (black cylinders): enter image description here

8
  • What would you like to see?
    – Zoltan
    May 10, 2020 at 10:27
  • I have edited my question above with a new screenshot. All cylinders should stand completely on the mountain surface, not underneath.
    – Jürgen
    May 10, 2020 at 15:11
  • Some thing strange for me with your DEM settings. Why do you have that vertical side? Did you set something in the 3D view properties of the DEM? The DEM should have no width.
    – Zoltan
    May 10, 2020 at 16:38
  • I use within den 3D settings "skirt height" to hide cracks. If this value is "0" the problem with the objects are the same. Read there: lutraconsulting.co.uk/blog/2018/03/01/…
    – Jürgen
    May 10, 2020 at 17:21
  • I cannot reproduce your situation. Can you try the same on a fresh QGIS installation or create a new user profile to have the default settings? I suppose some settings have been changed.
    – Zoltan
    May 10, 2020 at 17:29

1 Answer 1

0

OK. I have found a solution:

  1. I have reprojected the srtm1 raster with: raster - projections - warp(reproject) / target crs: in my case: WGS 84 / UTM zone 32N

(not a solution: change the raster layer to this crs)

  1. Edit the point layer with my zylinder: 3D: I have changed the translation "y" value (in my case "200")

Result: The same zylinder-height, but not the same total-height (terrain-height + zylinder-height) within the terrain. And no zylinder "under" the terrain. Example: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.