2

This seems to be a repeat of previous CRS errors in QGIS 3.10+

New install of QGIS 3.10.5-A Coruña LTR on clean install of Linux Xubuntu 20.04 (install from Ubuntu-LTR PPA and apt). This OS install accesses the /home folder from a previous Xubuntu 18.04 install.

To create the error/problem:

  1. Start a new project, QGIS defaults to EPSG:4326. No error messages.

  2. Change project CRS to EPSG:27700 (British Ordnance Survey) and a warning message appears:

    Used a ballpark transform from EPSG:27700 to EPSG:4326

The same error occurs if I use EPSG:7405 (also British Ordnance Survey). Selecting random CRSs or custom CRSs does not produce an error message: the error appears to be unique to British Ordnance Survey projects.

  1. Clicking on the error message Details gives:

    An alternative, ballpark-only transform was used when transforming coordinates between EPSG:27700 - OSGB 1936 / British National Grid and EPSG:4326 - WGS 84. The results may not match those obtained by using the preferred operation:

    Possibly an incorrect choice of operation was made for transformations between these reference systems. Check the Project Properties and ensure that the selected transform operations are applicable over the whole extent of the current project.

The project properties correctly state EPSG:27700. Moreover, this error occurs on a blank/empty project, therefore there have been no transformations attempted or performed.

  1. Creating a template file set to EPSG:27700 and starting a new project from the template file produces the same error.

No other solution(s) suggested.

Question: What is the practical effect of this error? I need to work to as high a level of accuracy as possible and certainly to better (less than) than 5m error. Do I need to worry about the error or not? Can I resolve the error?

QGIS 'About':

QGIS version 3.10.5-A Coruña

QGIS code revision 984615fe1e

Compiled against Qt 5.12.8

Running against Qt 5.12.8

Compiled against GDAL/OGR 3.0.4

Running against GDAL/OGR 3.0.4

Compiled against GEOS 3.8.0-CAPI-1.13.1

Running against GEOS 3.8.0-CAPI-1.13.1

Compiled against SQLite 3.31.1

Running against SQLite 3.31.1

PostgreSQL Client Version 12.2 (Ubuntu 12.2-4)

SpatiaLite Version 4.3.0a

QWT Version 6.1.4

QScintilla2 Version 2.11.2

Compiled against PROJ 6.3.1

Running against PROJ Rel. 6.3.1, February 10th, 2020

OS Version Ubuntu 20.04 LTS

Active python plugins mmqgis; LAStools; GeoCoding; quick_map_services; processing; db_manager

3
  • Do you have data outside the valid area of EPSG:27700 that is USAGE[ SCOPE["unknown"], AREA["UK - Britain and UKCS 49°46'N to 61°01'N, 7°33'W to 3°33'E"], BBOX[49.75,-9.2,61.14,2.88]]? – user30184 May 10 '20 at 18:53
  • No, the error occurs in a new project with no data whatsoever. Even when data is added it covers no more than 5 sq km in central England. The error appears to suggest that a transformation has or is being attempted when nothing is or has been attempted. – Snick May 10 '20 at 18:58
  • Edit: Based on other responses I have copied OSTN15_NTv2_OSGBtoETRS.gsb to /user/share/proj/ If I now start QGIS, create a new project, change the CRS to EPSG:27700, I still get the error. If I close the new empty project, I get the error again. If I now change the CRS in this new empty project I do not get the error. I can then add layers in OSGB:27700 without errors and save the project. If I then reopen that project, the error appears again. If I close all projects to show the QGIS recent projects list, the error message appears above all of the projects. – Snick May 10 '20 at 19:13
1

A message saying that QGIS does not have a suitable transform available (and is using a ballpark transform) indicates that there is a better transform available than that installed by the QGIS Standalone installer by default.

You can obtain updated grid shift files here (PROJ 7) or the updated legacy files (e.g., europe, north america, etc..)

PROJ 7.0 shift grids

0

QGIS 3.12 shows a rather detailed message that is promising an error of about 2 meters without shift grid file and 1 metre with the grid shift file. Could you update your QGIS and have a new try?

enter image description here

5
  • Only LTR releases are recommended for 'production' environments, therefore I am stuck with 3.10.5 for now. As noted above, I have the relevant shift grid file installed but continue to get errors. – Snick May 11 '20 at 8:17
  • Are you not even curious to know how QGIS 3.12 works with your data? If it works better you could also use that information if you would like to file an issue for QGIS 3.10. – user30184 May 11 '20 at 8:44
  • I have tried 3.12 in Windows, got the ballpark transformation message and installed the OSTN15 grid file as instructed. The message still appears. Technically, this is not an error, it is only a message alerting users to a potential error in processing OSGB data. However, the message about ballpark transformations does not specify the accuracy of the substituted ballpark transform: it might be 1m, it might be 10m, so the message is not of much use. Oddly, data downloaded direct from the Ordnance Survey is not given a custom CRS, not EPSG:27700. Why? – Snick May 12 '20 at 7:47
  • One solution (only brief testing so far but on 3.10.05 Linux) is to start the new project in EPSG:4326 as per QGIS default, then load the British data. QGIS may convert the CRS to EPSG:27700 or it may not. Importantly, adding data in 27700 should also invoke the Select Transformation dialogue box and present the seven transformation settings available; the first is these is accurate to 1m. The project can then be changed to EPSG:27700 if it has not transformed of its own accord. No messages at any stage. – Snick May 12 '20 at 7:55
  • I would send mail to QGIS-users mailing list. As a first aid I added qgis tag into your question. – user30184 May 12 '20 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.