1

I am trying to convert the Corine Land Cover Map (version CLC18) from .gdb format to .shp. I am working on QGIS. I tried Export>Save Feature as>ESRI Shapefile but it didnt work. The log file with the errors lives here: https://pastebin.com/8QiKw6nj Any ideas?

UPDATE:

Also tried using OSGeo4W with C:\>ogr2ogr -f "ESRI Shapefile" F:/n F:\DownloadsFromExplorer\clc2018_clc2018_v2018_20_fgdb/CLC2018_CLC2018_V2018_20.gdb . The error log file: https://pastebin.com/1Vypvr1f

  • 2
    Please share your errors and describe the way how does your initial shapefile look like with us. – Taras May 11 at 6:58
  • The log file with the errors lives here: pastebin.com/8QiKw6nj – chadoulis May 11 at 7:02
  • The initial file is in .gdb format. – chadoulis May 11 at 7:05
  • 1
    Seems like shape_length and shape_area fields are causing problems. Uncheck them in the export dialogue. They are not needed (or can be recreated later.) – BERA May 11 at 7:51
  • 2
    It seems that you have quite a large dataset and the size of the resulting shapefile exceeds the 4 GB limit ERROR 1: Failed to write shape object. File size cannot reach 4294960868 + 11320.. 4 GB is special for GDAL, the normal max limit is 2 GB. Use GeoPackage as outputformat instead. – user30184 May 11 at 9:41
1

The CORINE Dataset is a pretty big dataset with some long fields in the attribute table. The old and clunky shapefile can't handle both of these very well (at all).

See for example: SwitchFromShapefile

So if you do not really need it as a Shapefile for a specific workflow, which can't handle .gdb or even better .gkpg, then you can try what @BERA suggested. Otherwise I would strongly suggest to stay in .gdb or .gpkg because this type of file is really quite unsuitable for the shapefile format.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.