1

In QGIS I use this expression to build a "ID" from fields:

rpad(concat("abt", coalesce("u_abt",'X'),"beeinh"),5,'0') || '-Z01'

I need to translate this expression into a Excel or Calc function. How can I perform it?

  • What have you tried ? – Taras May 12 at 19:37
  • since I have no Idea, how to use Excel/Calc Syntax, I was hoping, someone does... – MAP May 12 at 19:40
  • 2
  • 1
    Did you try something like this =WENN(LÄNGE(VERKETTEN("abt"; VERGLEICH(FALSCH; ISTLEER(A2:C2); FALSCH); "beeinh")) < 5; VERKETTEN("abt"; VERGLEICH(FALSCH; ISTLEER(A2:C2); FALSCH); "beeinh") & WIEDERHOLEN("*"; 5 - LÄNGE(VERKETTEN("abt"; VERGLEICH(FALSCH; ISTLEER(A2:C2); FALSCH); "beeinh"))); LINKS(VERKETTEN("abt"; VERGLEICH(FALSCH; ISTLEER(A2:C2); FALSCH); "beeinh"); 5))&"-Z01"? – Taras May 13 at 6:07
  • 1
    Or in English =IF(LENGTH(CONCATENATE("abt"; MATCH(FALSE; ISBLANK(A2:C2); FALSE); "beeinh")) < 5; CONCATENATE("abt"; MATCH(FALSE; ISBLANK(A2:C2); FALSE); "beeinh") & WIEDERHOLEN("*"; 5 - LENGTH(CONCATENATE("abt"; MATCH(FALSE; ISBLANK(A2:C2); FALSE); "beeinh"))); LINKS(CONCATENATE("abt"; MATCH(FALSE; ISBLANK(A2:C2); FALSE); "beeinh"); 5))&"-Z01" – Taras May 13 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.