1

I am trying to set proper metadata on a mapserver 7.4.4 instance, based on this example:

https://mapserver.org/nl_NL/ogc/wcs_format.html#grib2-output-format

And WCS paramters like:

(wcs|ows)_band_interpretation (wcs|ows)_band_uom

That are well described on:

https://mapserver.org/ogc/wcs_server.html#new-band-related-metadata-entries

I have implemented something like this for testing:

LAYER
        NAME "MostProbable"
        PROJECTION
            'init=epsg:4326'
        END #PROJECTION
        EXTENT -180.0 -61.06747625006139 179.9999424001524 83.99916720600001
       METADATA
            'ows_title' 'WRB most probable class'
            'wcs_label' 'MostProbable'
            'wcs_rangeset_name' 'range1'
            'wcs_rangeset_label' 'label1'
            'ows_extent' '-180.0 -61.06747625006139 179.9999424001524 83.99916720600001'
            'ows_srs' 'EPSG:4326 EPSG:152160 EPSG:3857 EPSG:54009 EPSG:54012'
            'ows_abstract' ''
            'ows_keywordlist' ''
            'wcs_formats' 'GEOTIFF_BYTE'
            "wcs_bandcount" "1"
            "wcs_band_names" "band1"

            #default values
            "wcs_band_interpretation"   "Allo Allo this is nighthawk"
            "wcs_band_uom"              "class"
            "wcs_band_definition"       "test Definition"
            "wcs_band_description"      "Come in London"
            "wcs_interval"              "0 125"
            "wcs_significant_figures"   "3"

            #specific band values
            "band1_band_interpretation" "Listen very carefully, I shall say this only once"
            "band1_band_uom"            "class2"
            "band1_band_definition"     "SpecificDefinition"
            "band1_band_description"    "This is a specific description"
            "band1_interval"            "0 255"
        END

Doing a DescribeCoverage:

https://maps.isric.org/mapserv?map=/map/wrb.map&SERVICE=WCS&VERSION=2.0.0&REQUEST=DescribeCoverage&COVERAGEID=MostProbable

I dont see any changes on the response for example uom stays the default: <swe:uom code="W.m-2.Sr-1"/>

What could be the problem for the metadata not to be displaied on the DescribeCoverage response description, maybe I am missing something ???

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.