0

I am willing to model the distribution of an amphibian species in relation to climate and land cover in MaxEnt. For this I have downloaded the WorldClim data and the Global Consensus Land Cover (https://www.earthenv.org/landcover). The latter data consists of a raster file for each land cover class (open water, cultivated and managed vegetation,...etc.). However, I will not be using directly the raster of each land cover class, but instead a raster of the Euclidean distance of the XY coordiantes (longitude, latitude) where the species occurs from the nearest open water, cultivated and managed vegetation,...etc. I tried to calculate the Euclidean distance in ArcGIS 10.7.1 with the following: input raster (shapefile deature class of my occurrence data) and input barrier raster (open water raster). The Euclidean distance is calculated without errors but I get a blank raster with only one value (!) and I can not find where the problem is. Any thoughts?

0

I assume this is because you use degree as your unit, perhaps WGS1984 default projection? doing the euclidean distance in degree unit can produce raster with very little values, depending on your scale of analysis. I usually project them to UTM for small scale analysis:

  • Project all of your features, especially your occurrence, into UTM projection so that the units of your features are in meter. (using Project tool, or Project Raster tool)
  • change your dataframe coordinate system (View -> Data Frame Properties -> Coordinate system -> select the same projection that you used with the previous project tool
  • do Euclidean distance and set the environment setting (there should be environment setting on the bottom of your Euclidean Process window')
  • be sure to set snap raster the same with your landcover data.
  • you should also check your landcover data (after you do project raster) cell size, and set your euclidean distance output cell size the same.

This way it should be less risky for errors because you can make sure you have the same projections for each of your features. I hope this solves your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.