0

I installed PostgreSQL 12 on Ubuntu server 18.07. After the installation, I need to install PostGIS 3. i run this command "sudo apt install postgresql-12-postgis-3".

The following packages have unmet dependencies: postgresql-12-postgis-3 : Depends: libgdal20 (>= 2.0.1) but it is not going to be installed Depends: libproj12 (>= 4.9.0) but it is not installable Depends: libprotobuf-c1 (>= 1.0.1) but it is not installable Depends: libsfcgal1 (>= 1.2.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

How to install PostGIS on Ubuntu 18.04?

  • 2
    This isn't a GIS question as much as Linux package dependency issue. – Vince May 21 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.