-1

I am using QGIS Desktop 3.12.3 and QGIS Server and I have the following issue: a WMS generated based on a set of data stored in a Postgres db returns on GetCapabilities: <ServerException>Layer(s) not valid</ServerException>.

I also checked the QGIS Server logs and the error it is similar and it is too generic to know where to search.

0

One recent mention of this error can be found in https://github.com/qgis/QGIS/issues/33200:

IF instead of

FcgidInitialEnv QGIS_PROJECT_FILE "pc6project.qgz"

I use

FcgidInitialEnv QGIS_PROJECT_FILE "/usr/lib/cgi-bin/pc6project.qgz"

THEN the data is found...

This may solve your issue as well.

| improve this answer | |
  • Not working, I tried to do this – CatalinM May 21 at 19:55
  • It is like there is no connection to db – CatalinM May 21 at 20:40
  • 1
    I solved the problem, the issue was connection to DB, just like I suspected. – CatalinM May 22 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.