2

I need to transform a file in a .csv file into a LAS file. I have a LiDAR data folder, in this folder I have these files:

  1. A .csv file that contains the the point data
  2. Some metadata files (schema, HTML, MTD, SGML)
  3. A .csf file that is "An Intergraph Geomedia coordinate system file".

I am using txt2las to change the format but when I do this the LAS file does not have any reference, when I upload the new las file to ArcMap it says that is georeference system is unknown.

txt2las file.cvs -o file.las

I assume that the information about the geographic information is in the .csf but I don't know how to link it to the txt2las function.

Is there any way command txt2las to set a CRS from a .csf input? Or any other way to assign a CRS to the LAS file?

2
  • Are you able to read the content of the csf file? If yes what does it contain? If no do you have an idea of the expected coordinate reference system for your dataset? – JRR May 22 '20 at 9:41
  • No, I cannot open the csf file, I'm trying to open it with ArcMap, but honestly I don't know hoe to open it. And yes, I know my coordinate system, it is specified in the metadata – naNana May 22 '20 at 19:36
1

You don't need the csf file if you know your projection. You can set the CRS using the appropriated command

txt2las file.csv -o file.las -epsg 32754

The following is also valid

txt2las file.csv -o file.las -utm 17T

Check out the documentation of txt2las and las2las

5
  • Thanks, I'm doing that but it says: ERROR: unknown argument '-epsg', and when I do it with -utm it has the same error unknown argument '-utm'. Maybe I need to install something else? – naNana May 23 '20 at 15:22
  • Are you using LAStools or liblas? – JRR May 24 '20 at 8:20
  • I'm using liblas . I can install that package in Ubuntu but I'm not able to install LAStools package – naNana May 24 '20 at 17:25
  • I installed LAStools and it worked perfectly. Thanks! I still don´t understand why does not work with liblas ... – naNana May 24 '20 at 18:46
  • Because it is not the same software – JRR May 25 '20 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.