3

I want to have a default value from a current field (from another layer, but it is the same, when I use a current field from the current layer). And I DON'T want to update it automatically! After getting the current value as default value, I want to have the possibility to change the field value individual.

In 3.10 it is no more possible, there applies a warning “to use fields in default value is only working if you use update automatically default value”. But I don't want to update it automativally!: 3.10: default value with using given field value, warning without update automativally1

3.10: default value with using given field value, warning without update automativally2

In 3.4 is was possible and worked fine, I could have a default value from a current field without update it automatically:

3.4: default value with using given field value and without update automativally

Will it work again like in 3.4 in a newer version? Because of the warning it seems to be a wanted change and it doesn't seems to be a bug. But for me it is like a bug, I would like to work with 3.10 or newer. 3.4 I installed for test on an not used computer...

2

I found a solution for my problem. Even when I update the default value automatically and have a default value from current field, I can change the value afterwards. I just changed the default value from

attribute( get_feature( 'm_baeume_aktuellster', 'baum_p_id' , attribute( $currentfeature ,'baum_p_id') ) ,'baumart')

to

case when current_value( 'baumart') is null then attribute( get_feature( 'm_baeume_aktuellster', 'baum_p_id' , attribute( $currentfeature ,'baum_p_id') ) ,'baumart') else current_value( 'baumart') end

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .