2

In Qgis: I've got a point shape (EPSG:3398) with some height info and want to create a TIN interpolated raster with the Qgis TIN-Interpolation tool. But after running there was a raster created, which is invisible on the map and with impossible values and the the triangulation network only was made for the southern points like seen in the screenshot.

No Raster and corrupted TIN network

The point shape doesn't contain corrupted data.

Attribute table and properties

The settings of the TIN tool - no error message while running

My inputs for the TIN tool

The project EPSG is the same than the point shape. I'm running Q-GIS 3.12.3 on Linux Mint 19.2 (via apt).

What I've tried yet: Reproject the Point shape to different EPSGs; Change raster resolution ...with no success.

7
  • Seems like you are doing it correct. The Interpolation attribute needs to be numeric which it is and using RD/83 / 3-degree Gauss-Kruger zone 4 should work fine. The extent is I quess your view extent? If you want I can give it a go. – GISGILDE May 28 '20 at 21:37
  • 1
    As extend I've tried the layer extend as well as the view extend. I've added a drive Link to my post with the shape file. I'll take it off as soon as you've got the data. – David May 29 '20 at 9:42
  • David I took it of the drive. I will take a look at it. – GISGILDE May 29 '20 at 10:40
  • @GISGUILD Thanks! – David May 29 '20 at 11:28
  • It seems that there was a problem with the shapefile. I created a new one and it seems to work. The Tin Interpolation is now on 20% so I hope it will finish in the next hour. If this works correctly, I will write an answer and post the new shapefile + Raster in a wetransfer link. I will also write what I exactly did to overcome the problem and what might have caused the issue. – GISGILDE May 29 '20 at 11:36
2

David it took some time, but I managed to get the correct data for you using the TIN Interpolation Tool. However, there is a catch. During my research I came across this article from September 2019 on Github where somebody had the same problem having e+ values using QGIS 3.8.3.

https://github.com/qgis/QGIS/issues/31970

In this article the statement was made:

The extent of the output and the pixels size are likely to not match perfectly, so there must be some rounding......

So I started testing your shapefile and your Tiefe NN seemed 162.600. But it constantly returned 1.79769e+ 308. I used the layers extent. When I exported it as a .CSV file it created an error. When I exported it as .XLSX and imported it again, the Tiefe NN was not 162.600 but 162.599 (with really a lot of extra decimals). So I created a new attribute field with one decimal, and my first test returned fine as you can see. I tested the most southern part (1341 features).

enter image description here

So your initial question, your raster was invisible and the values impossible, is solved. But now your real problem. When I expend the test with more points (1809 features) this result was returned.

enter image description here

The reason for this is also explained in that article.

To honor the pixel size (ex. 0.25) the tool could simply round the xmin/ymin coordinates DOWN to the nearest whole pixel size and the xmax/ymax UP to the nearest whole pixel size. When doing this manually through the extent parameter, the values are not honored. Padding with extra pixels (rows/columns) is not possible either.

However, this new problem does not really provide you with a satisfying solution. But there is hope. Two days ago a new comment was placed on this article by Alexbruy with following link and title:

Fix calculating raster size in the TIN and IDW algorithms to maintain accurate pixel size https://github.com/qgis/QGIS/pull/36822

Here it is stated that the issue was fixed and is added to the Qgis 3.14.0 milestone. On the QGIS.org website it is stated that 3.14.0 is planned to be released on the 19th of June 2020.

I hope that this would solve your problem completely.

In the following wetransferlink I have the shapefile that I made from your original shapefile. Instead of using Tiefe NN use Hight (I know it is Height in proper English).

[Later EDIT by GISGUILD]

Since I understand that you need the data I made a Interpolated TIN raster for you in ArcGIS PRO. I will add this raster to the Wetransfer link. Simply browse to the RASTER folder and drop the entire tin raster folder in QGIS.

Good luck!

https://we.tl/t-JSRNiAfaVt

enter image description here

1
  • Can I remove the Wetransferlink? – GISGILDE Jun 1 '20 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.