So I clipped two rasters and tried to merge them but every time I merge them I'm getting a black rectangle background that I don't want. Tried clipping again with the shapefile but getting a black square background. I'm a newbie to QGIS(recently shifted from ArcGIS) and skimmed through the documentation once and don't know how to fix this. Here's some screenshot and the data I'm using:


enter image description here

enter image description here

enter image description here

1 Answer 1


It looks like your No Data values are getting lost in the merge. Look in the properties of the layer for the no data value. -200 in your case (not a no data value I am used to seeing) no data in properties Then set the no data in the output to the same. (-200) merge algo no data output

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.