0

I'm trying to calculate vegetation indices via the QGIS raster calculator using two separate bands of a Sentinel-2 tile (both of which have the same extent and CRS) but the resulting image is split in two. The result has the same extent as the input images and reference layer but appears to be split between two horizontally compressed images. I've attached the result below.

This doesn't happen with any other Sentinel-2 tile I have used for the same purpose using the same raster calculator expressions. Any help would be appreciated! Raster calculator result

  • Please provide the expression you're using, as well as any information on the data you can share, especially as to how it is different from your other data. – Erik Jun 5 at 8:44
  • All expressions applied to this data are producing this result, even a simple Raster1-Raster2. Data are sixteen bit unsigned integer singleband images in .jp2 format. This is the same as all other Sentinel-2 data I have worked with and had no issues. – Duncan Martyn Jun 5 at 9:20
0

Disabling OpenCL acceleration solved this issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.