0

I have installed QGIS 3.12 through the Ubuntu Store and installed Saga 7.3.0 through:

sudo apt-get install saga

I tried to install QGIS through apt-get, as instructed in the documentation of QGIS but this resulted many errors on dependencies which were impossible to install. I did not run into these issues when install QGIS from the Ubuntu store.

However, I cannot find the SAGA tools in QGIS. I ticked the activate box in the Processing settings but still, no sign of any SAGA tools in the processing toolbox.

Many thanks in advance!

Printscreen of of Processing Options

  • You do not mention which saga version you have installed, maybe 2.3.1. The ubuntugis unstable ppa has saga 7.3.0 for bionic, and that should work with QGIS from the same PPA. – AndreJ Jun 11 at 11:00
  • Thank you for the tip, I added the version (7.2.0). It is still not working but probably they are not in the same PPA, how do I check this? – IgnaceP Jun 12 at 12:04
  • This worked for me: gis.stackexchange.com/questions/345121/… – GBG Jun 13 at 17:39
  • Maybe related: github.com/qgis/QGIS/pull/33253 – AndreJ Jun 13 at 19:33
0

QGIS 3.12 for Windows standalone comes with SAGA 2.3.2, so I assume they are not yet ready to support the new SAGA version 7.3.

Using Ubuntu, you have to remove the 7.3.0 version from the ubuntugis unstable PPA completely, and take version 2.3.1 from the main Ubuntu repo.

SAGA 2.3.1 might not be compatible with GDAL 3.0.4 from Ubuntugis unstable PPA, so you have two choices at the moment:

  • take the latest GDAL and SAGA from ubuntugis, but have no integration in QGIS
  • take the QGIS ubuntu repo, and GDAL and SAGA from the main ubuntu repo. This should enable SAGA in QGIS again.

You can make use of a virtual box to run both choices in parallel with shared folders to exchange data sources.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.