I'm trying to export in GeoPDF my map from QGIS 3.12.

After updating QGIS 3.6 to 3.12 can't recognize the project CRS EPSG 3120 for raster file and vector layer which is the color layer then I tried to reproject both of layers.

The raster was reprojected correctly with the projection EPSG 3120 but the vector layers still with Unknown CSR :

(Unknown CRS: PROJCRS["Pulkovo_1942_58_Poland_zone_I",BASEGEOGCRS["Pulkovo 1942(58)",DATUM["Pulkovo 1942(58)",ELLIPSOID["Krassowsky 1940",6378245,298.3,LENGTHUNIT["metre",1]],ID["EPSG",6179]],PRIMEM["Greenwich",0,ANGLEUNIT["Degree",0.0174532925199433]]],CONVERSION["unnamed",METHOD["Oblique Stereographic",ID["EPSG",9809]],PARAMETER["Latitude of natural origin",50.625,ANGLEUNIT["Degree",0.0174532925199433],ID["EPSG",8801]],PARAMETER["Longitude of natural origin",21.0833333333333,ANGLEUNIT["Degree",0.0174532925199433],ID["EPSG",8802]],PARAMETER["Scale factor at natural origin",0.9998,SCALEUNIT["unity",1],ID["EPSG",8805]],PARAMETER["False easting",4637000,LENGTHUNIT["metre",1],ID["EPSG",8806]],PARAMETER["False northing",5467000,LENGTHUNIT["metre",1],ID["EPSG",8807]]],CS[Cartesian,2],AXIS["(E)",east,ORDER1,LENGTHUNIT["metre",1,ID["EPSG",9001]]],AXIS["(N)",north,ORDER[2],LENGTHUNIT["metre",1,ID["EPSG",9001]]]] - Projected)

Should I reinstall an older version of QGIS ?

enter image description here

1 Answer 1


The axis order of the CRS definition is not the axis order of the EPSG:3120.

Just export the shapefile layer to a GeoPackage with the EPSG:3120 CRS.

Should I reinstall an older version of QGIS ?

Consider stopping using shapefiles if you want to step forward instead of back.

  • I am having the same problem. Gabriel, Could you please explain your comment: "Consider stopping using shapefiles if you want to step forward instead of back."
    – seichner
    Feb 8, 2021 at 18:28
  • CRS definition for shapefiles wasn't a standard, partially standarized in WKT:2015. You can install an old QGIS version to use it. Feb 8, 2021 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.