0

I have a large QGIS projekt with about 50 layer, several of which are QuickMapService Base maps or other WMS-Layers. I work with this project for over a year now and had no problems.

I run QGIS on a Manjaro-Linux platform. Recently my QGIS was upgraded to 3.12 against my will and was very unstable afterwards. I reinstalled the LTR 3.10.6 from the AUR. Since then the following problem occurs very frequently.

I can load my project without issues and work for a while, but when zooming QGIS appear to have issues loading the maps. The map window turn blank and the status bar indicates constant activity, for as long as you want to wait. Neither raster nor vector data are rendered. When trying to close QGIS it indicates, that a process is still running. When restarting QGIS, the project works fine until the issue starts again.

1

This is a bug, see https://bugs.archlinux.org/task/67057?project=5&string=qgis.

The Qgis-issue is here: https://github.com/qgis/QGIS/issues/37272; this ticket has been closed in the meantime, because it seams to be an Arch-issue only.

1
  • The github-link above does not seem to work, so here it is again: github.com/qgis/QGIS/issues/37272 According to the comment by JohnProv in that threat it helps to disable the multithreading for map rendering (Options > Rendering > uncheck 'Render layers in parallel using many CPU cores'.) I have tried that and it appears to work much better now. – C.-F. Vintar Jun 24 '20 at 10:10
0

This problem has been solved in the meantime. It was a bug in qt. See the comments in https://bugs.archlinux.org/task/67057?project=5&string=qgis

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.