-1

Good afternoon,

I would like to overlay my .csv comma delimited layers in QGIS 3x properly. I have got the Ordnance Survey Maps as the raster players, which CRS is EPSG 27700 1936 British National Grid. I overlaid these maps with my .csv data, where I set EPSG 4326: WGS 84. As a result, the data is visible, although there are some mismatches, as you can see below: enter image description here

In the following example, you can see, that the difference is quite big, as the pole appears on the other side of the road effectively. I theoretically know, that the mismatch is driven by different CRS between the comma-delimited layers (WGS 84) and the map layer (British National Grid).

When I change the CRS for my comma-delimited layers, then they don't appear in my location anymore. Their new place is somewhat at the beginning of the coordinate system, as you can see below:

enter image description here

I would like to make sure, that all these layers match to each other as much as possible. What should I do then?

  • Are you sure that the pole was recorded correctly and the difference isn't just a lack of accuracy in the CSV file? If you can confirm that in the data is being distorted by the CRS on the fly transformation there are different transformation settings that you can set in QGIS. – Baswein Jun 24 at 16:01
  • I am sure of the pole location is accurate. As far as I know there is no "On the fly" transformation option in QGIS 3x. Why the points are freaking out, when I set the British National Grid, which is exactly the same for the map underneath. This is what I don't understand here. – MKR Jun 24 at 16:04
  • I think it is more like in QGIS 3 there is just no way to turn "on the fly" transformation off. I assume that you are just changing the CRS in properties. That will give you the weird results you encountered. To change the CRS you would have to reproject it (save as). Here is a description of those differences reddit.com/r/QGIS/comments/frl2ae/… Forgive me if you are already familiar with them. The other thing that could be happening is if the the CSV where encoded in a slight variant of 4326. – Baswein Jun 24 at 16:29
  • 1
    The way to disable on-the-fly reprojection in QGIS3 is by selecting No CRS for the map (i.stack.imgur.com/6MtqQ.png), but you don't need that because each layer will be shown in their own reference system. Seems to me that you don't have installed the grid for the datum transformation for OSGB 1936 datum. I don't have it and projinfo -s EPSG:27700 -t EPSG:4326 returns: Grid OSTN15_NTv2_OSGBtoETRS.gsb needed but not found on the system. Can be obtained from the proj-datumgrid-europe package at https://download.osgeo.org/proj/proj-datumgrid-europe-1.5.zip – Gabriel De Luca Jun 24 at 23:41
  • 1
    I think the first thing I'd do is check the coordinates for the features that don't plot accurately. For example, you could probably see that pole in Google Earth and obtain an accurate coordinate for it to compare with the equivalent one in your CSV file. – nhopton Jun 25 at 8:47
4

EPSG:4326 (WGS 1984, degrees of longitude and latitude) seems to be correct, as the deviations are very small. QGIS (and hence Proj) might have inaccurate transformation parameters for "EPSG 27700 1936 British National Grid" that could cause the effects that you are reporting. But there could be other reasons - your positions may be inaccurate (could be the case if they are collected with a hand-held GNSS/GPS device), or there may not be enough decimals for the coordinates in your CSV file.

By the way, setting the CRS for a dataset will not transform it. You have to either Export-> Save as (and choose the CRS you want to transform to) or run the algorithm Reproject layer (from the Processing Toolbox).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.