0

I have been working on some basic functions such as joining data and producing maps on Win10 using QGIS3.10 app. I am quite sure that the everything was still fine yesterday however, today the app start crashing all the time when I start working on the properties.

The data I have been working with is a CSV file edited by MS Excel with pivot table function, to be joined with .shp file

5
  • 1
    Hi and welcome to GIS.SE! Could you include some more information on the data you are using and be more specific on the problem?
    – root676
    Commented Jun 24, 2020 at 16:50
  • thanks for the tips, its updated!
    – brygid
    Commented Jun 24, 2020 at 17:34
  • 1
    Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works.
    – Ian Turton
    Commented Jun 24, 2020 at 19:09
  • thanks for the guidance @IanTurton :)
    – brygid
    Commented Jun 24, 2020 at 21:04
  • after reorganizing the data folder the problem is solved.
    – brygid
    Commented Aug 15, 2020 at 13:59

1 Answer 1

3

Crashes are frustrating, and often hard to debug, especially when you feel you're not doing anything out of the ordinary and replicable which didn't cause a crash before.

Here's my generic advice for situations like this:

  1. Create a new, clean profile (under Settings / User Profiles). You will lose and/or have to recreate certain default settings, but fairly often QGIS crashes are caused by something (internal to QGIS, a plugin?) corrupting your user profile. Does that fix the problem?

  2. Reinstall the software from scratch, ideally on a different machine, to test the hypothesis whether your installation has gotten corrupt. In your case, rather than the latest LTR (currently 3.10.7, make sure you don't have an out of date one), try also the latest regular version, currently 3.14.0. While the LTR is usually more stable, it's always possible you're running up against something recently fixed. If this were the case, you then decide how you want to proceed long term (LTR or current release), but at least you test it out.

  3. Simplify QGIS' life. A layer from a csv file joined with a shp should work, and certainly shouldn't crash, but try a) working with the layers without a join, b) exporting the csv layer and/or the joined layer as its own gpkg or shp layer.

I've added 3) more as debugging than as a solution, to at least find out what is causing QGIS to stumble. Pay particular attention to making sure the field type for any joined fields is the same. It should be recast where needed, and shouldn't cause QGIS to choke if there is a problem, but it is an example of needless complexity that could I guess cause problems.

Once you do find the source of the problem, please do post it as a bug report at https://github.com/qgis/QGIS/issues They can't help you troubleshoot why you in particular are having a problem, but crash-causing problems especially in the LTR should get fixed when pinpointed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.