0

Recently I solved the problem regarding the mismatch between British National Grid CRS and WGS 84 in the query below:

QGS 3x Ordnance Survey map doesn't overlay the Google Maps properly

I downloaded the .gsb file and copied it into the relevant folder like shown in the instructions.

However now I see, that this .gsb file (with custom CRS) is valid for one layer only. I can't see it for other Ordnance Survey Maps...

enter image description here

You can see the layer above with "Unknown CRS" (located in unknown Coordinates System section) which comes from the copied .gsb file unlike another layer below, which doesn't have this layer in the search box at all.

enter image description here

  • 1
    First, QGIS 3x is not enough reference to get the version, there was a great change in CRSes definitions between different QGIS 3 versions. Also important information, do you have the default datum transfomation defined in the project properties or in the QGIS settings (or both, or none of them)? Is the raster layer with the unknown CRS a derived product of a QGIS process or is it a layer added from a external source file? These questions are because the definition of the layer include the datum transformation, so it is an EPSG:27700 layer which include in its definition how to transform it. – Gabriel De Luca Jun 26 at 21:32
1

It looks like your data files are coming from a program that has a different idea of the correct WKT definition of EPSG:27700 is than QGIS has. But this doesn't actually matter, QGIS seems to have still parsed it and used it to align your layers.

If you are really worried about this then use Set Layer CRS to set the layer to EPSG:27700 (this will not in any way move the actual data) to update the metadata (so called) of the shapefile so that its definition agrees with what QGIS is expecting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.