1

All the other questions I've seen so far are a step ahead of me. I've defined an Input for a vector layer, and am trying to use the Select by Location Algorithm. I typed the name of my Input, but the modeler doesn't seem interested in connecting it. Any ideas? enter image description here

2
  • Which Version of QGIS? (3.14 was only recently released - it may have improvements in this area) qgis.org/en/site – Mapperz Jun 26 '20 at 16:29
  • Err mine's at 3.6.1-Noosa! In any event, would that impact what seems like a fairly straightforward algorithm? I tried some other algorithms and I was able to select my created input, but seems strange that this specific one doesn't want to connect. – JNg Jun 26 '20 at 16:39
0

Got it - I initially left the geometry type as "Not Required" - selected Polygon and now I can interact with it.

1
  • I'm actually having the same problem, and this solution does not seem to help. I have defined the type of the vector layer in the input, but I still don't seem to be able to select as a parameter for subsequent algorithms. Typing in the name of the parameter manually also doesn't seem to help. Do you have any further thoughts? – Lukasz Sep 23 '20 at 9:57
0

Update for QGIS 3.14 - from QGIS graphical modeller joining input layers to processing algorithms

To select something else that a layer in the current project - such as model input, or output of another algorithm in the current model - the category of input has to be defined first using the '123' button:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.