0

Is anyone successfully using SAGA tools in QGIS 3.10.7?

I have downloaded QGIS 3.10.7 on multiple PCs and a Mac. All of them have resulted in the same problem when I try to run SAGA tools. A message similar to:

"The following layers were not correctly generated. C:/Users/Admin/AppData/Local/Temp/processing_7cf0f5b0db874bb9a6b8fe84b44cb047/2a6b2113845f4739b4dec0f12c451504/C_PROF.sdat" You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm."

I've downloaded QGIS from the QGIS Standalone Installer Version 3.14 (64bit) and the OSGeo4W Network Installer (64bit)

Here are images of the 'Log Messages Panel'

enter image description here

enter image description here

enter image description here

enter image description here

I am not seeing anything in the log that suggests why the layers were not correctly generated. It ultimately generates a layer with reasonable looking values, but I am concerned about their accuracy given the warning.

More specifics:

  • I have tried to run SAGA tools using an ASCII file and TIFF file.
  • Files that I have tried range from ~250MB to 1.7GB
  • I am using a projected coordinate system - EPSG:26919 - NAD83 / UTM zone 19N - Projected
  • I have set the project CRS to match the layer CRS before attempting processing

Anyone successfully using SAGA tools with QGIS 3.10.7? If so, any ideas what is causing this problem for me?

  • I have an older version of QGIS (2.12.3 - Lyon). When I use the same SAGA methodology and data on QGIS (2.12.3), it does not say that, "The following layers were not correctly generated," like it does with QGIS (3.10.7). And, the values that are created with QGIS (2.12.3) and QGIS (3.10.7) are exactly the same. Should I ignore the message provided by QGIS (3.10.7) that "The following layers were not correctly generated." I am going to be publishing this data, so I want to be sure that the data are correct. – nateroe Jul 1 at 13:31
  • A friend who uses QGIS (3.10.7) told me he gets the same warning when running SAGA tools - "The following layers were not correctly generated." Could others please tell me if they are successfully/unsuccessfully using SAGA tools with QGIS (3.10.7). 3.10.7 is the long-term, stable release of QGIS and I think it would be good to know if SAGA tools work properly on this release. Here is a link to raster data if you need some to check with. unh.box.com/s/m7kiz5c980rre8ws285feoxfqfsf0z3q – nateroe Jul 1 at 13:38
  • The same warning is produced from the most recent, development version of QGIS (3.14.0) – nateroe Jul 1 at 14:33
  • I don't have enough reputation to comment... I am also UNABLE to get SAGA tools to work with QGIS. (3.10.7, 3.12.1, 3.14.0) on a Mac running 10.14.6. The tool I am trying to use works intermittently. When it does work I get the same error you listed above. When it does not work it simply freezes until I force quit QGIS. I was using 'Natural Neighbor' on three sets of GPS points. It works on some data sets and not on others (all shapefiles in my case and working on the set with about 250 points but not on the other two with fewer points) – Richard Rasch Jul 1 at 18:18
0

Please convert this to a comment too. The OP asked for clarification (inside his own comment) as to whether the tools are working or not. They are not working for me so should the OP be denied this information because I don't have enough reputation? (I have been a member of Stack Exchange for 4 years and still can't comment over there so no telling when I could have provided this insight as comment here on GIS area.

| improve this answer | |
0

This is an ongoing issue, at least since QGIS 3.6.0. Despite the warning, the values that are produced seem to be correct. Read this thread for a conversation on the topic. https://github.com/qgis/QGIS/issues/29346. It appears that similar warnings can be produced using GDAL through QGIS also.

As I commented above, I have performed the same SAGA calculations using QGIS 3.10.7, 3.14, and 2.12.3. QGIS 2.12.3 does not report any error, QGIS 3.10.7 and 3.14 do. Despite the error, all three versions result in the same values being produced.

Considering this and the conversation in the link provided suggesting that the values are correct and the warning is innocuous, I believe that the warning can be ignored and values can be trusted.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.