0

Context

(see bottom EDIT for the fix, thanks to ThomasG77)

After having run my daily updates using; apt update && apt upgrade, on Ubuntu 18.04 I've seen that QGIS 3.14 was newly shipped and installed. That's cool!

But now, I'm not able to open it according to this error:

$ qgis
/usr/bin/qgis.bin: error while loading shared libraries:
libprotobuf-lite.so.10: cannot open shared object file:
No such file or directory

But I actually have more recent protobuf-lite libraries:

$ find /usr -iname "*libprotobuf-lite*"
/usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.15.0.1
/usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.15
/usr/share/doc/libprotobuf-lite10
/usr/local/lib/libprotobuf-lite.so
/usr/local/lib/libprotobuf-lite.so.18
/usr/local/lib/libprotobuf-lite.a
/usr/local/lib/libprotobuf-lite.so.18.0.0
/usr/local/lib/libprotobuf-lite.la

This is my apt source file for QGIS:

$ cat /etc/apt/sources.list.d/qgis.list
deb http://qgis.org/debian bionic main
deb-src http://qgis.org/debian bionic main

And If I try to reinstall it:

$ apt-get install qgis python3-qgis qgis-plugin-grass
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-qgis is already the newest version (1:3.14.0+28bionic).
qgis is already the newest version (1:3.14.0+28bionic).
qgis-plugin-grass is already the newest version (1:3.14.0+28bionic).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y

That's the result:

Setting up qgis-providers (1:3.14.0+28bionic) ...
/usr/lib/qgis/crssync: error while loading shared libraries: libprotobuf-lite.so.10: cannot open shared object file: No such file or directory
dpkg: error processing package qgis-providers (--configure):
 installed qgis-providers package post-installation script subprocess returned error exit status 127
dpkg: dependency problems prevent configuration of qgis:
 qgis depends on qgis-providers (= 1:3.14.0+28bionic); however:
  Package qgis-providers is not configured yet.

dpkg: error processing package qgis (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-qgis:
 python3-qgis depends on qgis-providers (= 1:3.14.0+28bionic); however:
  Package qgis-providers is not configured yet.

dpkg: error processing package python3-qgis (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qgis-server:
 qgis-server depends on qgis-providers (= 1:3.14.0+28bionic); however:
  Package qgis-providers is not configured yet.
 qgis-server depends on python3-qgis (= 1:3.14.0+28bionic); however:
  Package python3-qgis is not configured yet.

dpkg: error processing package qgis-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
 No apport report written because MaxReports is reached already
                                                               dpkg: dependency problems prevent configuration of qgis-plugin-grass:
 qgis-plugin-grass depends on qgis (= 1:3.14.0+28bionic); however:
  Package qgis is not configured yet.

dpkg: error processing package qgis-plugin-grass (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 qgis-providers
 qgis
 python3-qgis
 qgis-server
 qgis-plugin-grass
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question

Is this a known issue?
How can I fix it?

  • sudo apt install libprotobuf-lite10 and try also sudo apt install -f after to fix the broken install – ThomasG77 Jun 28 at 9:43
  • This tells me libprotobuf-lite10 is already the newest version (3.5.1+6-0bionic1). and then I fall back on the same results. And if I add the --reinstall flag to apt install, it says: Reinstallation of libprotobuf-lite10 is not possible, it cannot be downloaded. – s.k Jun 28 at 10:03
  • Surprised because packages.ubuntu.com/bionic/libprotobuf-lite10 . Moreover, I don't see where your protobuf version comes from (version 15 and 18 are not in the ubuntu repositories e.g packages.ubuntu.com/…). – ThomasG77 Jun 28 at 10:54
  • I remember not very well, but I had to deal with these versions while compiling machine learning stuff some time ago (tensorflow related) which needed at least version 15 of libprotobuf... – s.k Jun 28 at 10:57
  • 1
    For QGIS (it may break your ML part), download manually libprotobuf-lite10 by downloading packages.ubuntu.com/bionic/amd64/libprotobuf-lite10/download and install it (if your system does not ask to install do sudo dpkg -i libprotobuf-lite10_3.0.0-9.1ubuntu1_amd64.deb) and try again apt-install -f – ThomasG77 Jun 28 at 11:04
0

As suggested by TomasG77 in the comment above, a manual download (from one of the mirrors here: https://packages.ubuntu.com/bionic/amd64/libprotobuf-lite10/download) and reinstall of the libprotobuff-lite10 package using:

dpkg -i libprotobuf-lite10_3.0.0-9.1ubuntu1_amd64.deb

have solved the issue:

$ dpkg -i libprotobuf-lite10_3.0.0-9.1ubuntu1_amd64.deb 
dpkg: warning: downgrading libprotobuf-lite10:amd64 from 3.5.1+6-0bionic1 to 3.0.0-9.1ubuntu1
(Reading database ... 705196 files and directories currently installed.)
Preparing to unpack libprotobuf-lite10_3.0.0-9.1ubuntu1_amd64.deb ...
Unpacking libprotobuf-lite10:amd64 (3.0.0-9.1ubuntu1) over (3.5.1+6-0bionic1) ...
Setting up libprotobuf-lite10:amd64 (3.0.0-9.1ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...

Then a simple check on this package with apt has directly fixed QGIS pending issues:

$ sudo apt install libprotobuf-lite10 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libprotobuf-lite10 is already the newest version (3.0.0-9.1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up qgis-providers (1:3.14.0+28bionic) ...
Setting up python3-qgis (1:3.14.0+28bionic) ...
Setting up qgis-server (1:3.14.0+28bionic) ...
Setting up qgis (1:3.14.0+28bionic) ...
Setting up qgis-plugin-grass (1:3.14.0+28bionic) ...
W: APT had planned for dpkg to do more than it reported back (12 vs 16).
   Affected packages: qgis-providers:amd64
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.