0

I moved my database and shape files, and wanted to relink them to my QGIS project. The shape file worked fine, but the CSV file wasn't reloading properly no matter what I tried. I could see the fields and the attribute table all fine, but the points just wouldn't appear, and there wasn't even a checkbox to the left of the layer in the layers panel like there usually is.

I don't want to remove the layer and re-add it, although that did work in making it visible. But then I would lose all the properties that I've already set to that layer.

I'm using QGIS v3.14.

I'm new to QGIS and mapping in general.

  • that usually means you've "lost" the geometry attribute - check that you included the X/Y columns – Ian Turton Jun 29 at 7:23
  • how do I do that? I know that when I import the csv I can select the x and y fields. but when it's already imported, where can I select them? I can see the fields in the attribute table but maybe they're not connected to the geometry like you're saying – fadelm0 Jun 30 at 17:14
1

you could in the still working project right click your csv-layer -> export -> Save as QGIS Layer Style File and save all the styling/forms etc to one single file. Then move your project, load the csv again, right click it -> Properties. Here in the very left bottom you will find the button "Style". Click on it, "load style", navigate to where you saved the layer style file and you should be good :)

| improve this answer | |
  • that's a nice workaround. but when I do that, the labels that I moved are reset, and for some reason I can't move the labels anymore. while in the original file with the same style I was able to move the labels. do you know why that might be? – fadelm0 Jun 30 at 17:19
  • you might consider to ask this in a seperate question. i have no idea to be honest, maybe you move your data from the csv into a .shp as well and see if that solves the problem? – sn1ks Jul 1 at 5:47
  • it's ok, I will figure it out. your answer solves it for now, thank you! – fadelm0 Jul 1 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.