0

I downloaded a GPX file from a tourism web site. However, when I tried to import this file to Google Earth or Garmin's Basecamp, they both complained that the file format was wrong. I opened the GPX file and noticed that the latitude and longitude numbers where quite high : an exemple is for instance : <rtept lat="6923211.8424401991" lon="367940.01590696711">

I looked at the file header and noticed that there was some kind of translation rule :

<extensions>
    ....
    <ogr:XW84>-1.56894</ogr:XW84>
    <ogr:YW84>49.322</ogr:YW84>
    <ogr:XL93>367940.01591</ogr:XL93>
    <ogr:YL93>6923211.8424399998</ogr:YL93>
  </extensions>

I think that this says that a latitude of 6923211.8424399998 should correspond to 49.322

Can somebody confirm that ? Do you know if there is any tool to correct such format ?

Here's a link to the complete file.

1
  • If you can provide a link to the gpx might help. Those Lat/Lng values should be to 6 decimal places for accuracy and might be why basecamp is complaining.
    – Mapperz
    Jul 5 '20 at 16:43
3

You did not state from which area your file is, but your coordinates show that it is in the northwest of France. So what I did is looking for the exact location that the sample coordinates in your post refer to. Then I used this tool to see which Coordinate Reference Systems (CRS) are valid for this area: http://www.epsg-registry.org/

enter image description here

I zoomed in on the map to the area of interest and defined a projected CRS (because the coordinates in your file are apparently defined in a projected CRS). The resulting list had a few CRS valid for this region.

enter image description here

The ogr:XL93-tag in your file is a hint that it should be one of the CRS containing the number 93. So in QGIS, I loaded your gpx-File and an OpenStreetMap basemap and than assigned the CRS-codes from the result to the gpx-layer (right click on layer, set CRS, set CRS for layer). After a few attemtps (zoom to layer after each operation of setting CRS), it resulted that your path is shown correctly with this CRS: RGF93 / Lambert-93 EPSG::2154

So now I just had to export your gpx to a new gpx file, but this time (attention) select 4326 as CRS for the file to get standard GPS-coordinates. You can download the file from here: https://drive.switch.ch/index.php/s/eIaUTYymGpLFXL7 I tested it in Google Maps, works correctly there.

Update: There is an online tool to convert your gpx files, if you have more than just this one: https://mygeodata.cloud/converter/gpx-to-latlong Upload your file and than set the parameters accordingly (pay attention especially to choose the correct CRS for your input file and be sure to set CRS to 4326 for your export file):

enter image description here

1
  • Thanks a lot babel !
    – Aguelmame
    Jul 5 '20 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.