2

I have QGIS 3.12, running on Win 10 x64, with an i5-9600k cpu, 16GB DDR4 RAM 4000MHz, an NVIDIA Quadro P2000 Graphics card and very fast SSD (Samsung 970 EVO Plus 1 TB PCIe NVMe M.2). In QGIS, I have enabled "Render layers in parallel' using all 6 CPU cores.

I have a QGIS project. One of the vector layers is based on a shp file whose dbf file is 130MB. Another layer is 16MB. I have created spatial indexes for all layers.

But QGIS is very slow at panning and zooming in and out. Typically freezing for 20 seconds or so. Every now and again I get short periods of fast panning and zooming. Task manager shows shows CPU activity never really goes above 25%. GPU activity is never more than 5%, and the disk activity barely registers.

The same dataset in Manifold GIS shows no such 'laggy' behaviour.

Is this just an issue with QGIS, or is there something I can do to speed it up?

5
  • 2
    What is the size of shp files? Are your layers in same coordinate system / projection or reprojejecting on the fly? If some layers are multipolyline / multipolygon and/or features have huge bounding boxes or huge number of vertices, that might also cause troubles, as spatial index is not that helpful in such cases. There is more things to consider, without looking at particular dataset it is hard to tell what exactly can be wrong.
    – Miro
    Jul 7, 2020 at 14:38
  • HI Miro. There is one shp file is 16MB (with a dbf file of 130MB). There are four other layers, one with a DBG of 1.6MB, and another of 1MB. All are projected to the same CRS, no reprojection on the fly. There are no multi-points, lines or polygons.
    – Oisin
    Jul 7, 2020 at 15:21
  • is the virus scanner on?
    – Ian Turton
    Jul 7, 2020 at 15:44
  • 2
    You can try save this files in geopackage format and see the performance. There any raster file together?
    – hugonbg
    Jul 7, 2020 at 16:21
  • 1
    Make sure you turn off all plugins too -- it could be a bad plugin causing issues
    – ndawson
    Jul 7, 2020 at 17:25

1 Answer 1

2

I noticed that keeping my data on the C drive makes a major difference even with Geopackage data. If your data is on a server or on a different drive, try moving it to the C drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.