1

I am using ArcMap 10.7 to map data points (decimal degrees) across eight countries. I have an Excel .csv file that contains the data points (548 rows), but when I import the data (as a .csv) and try to "Display XY data", some of the points do not display. Note: all of these points are in one country. Within Excel, I double-checked that the latitude and longitude values for this country are correct (they are). I have plotted these same data coordinates (decimal degrees) in a smaller excel .csv before, and they displayed in ArcMap.

Here are the steps I followed to import my data:

Option 1: Catalog -> Navigate to folder containing .csv file -> Drag .csv file into Data frame -> Use "Make XY Event Layer" from the ArcToolbox -> Select Latitude (Y) and Longitude (X) -> Add to map

Option 2: File -> Add Data -> Add XY Data -> Select file -> Select Latitude (Y) and Longitude (X) -> Add to map

Both of these scenarios did not display all data.

Problem:

Some locations not appearing in Display XY data

Solutions I've tried:

  1. Import dataset as a .csv file into an empty ArcMap document (i.e. no basemap or other shapefiles present).
  2. Re-save Excel .csv file as a new .csv, re-import into ArcMap
  3. Clear formatting of .csv, re-save as a new .csv, re-import into ArcMap
  4. Delete all other rows in .csv besides Latitude, Longitude and "Country", then re-save .csv and re-import into ArcMap
  5. Click .csv file in Table of Contents, click Data -> Export -> Save as dBase table -> Add to map as layer
  6. Open up old .csv where the data for this country appeared, copy these data into a new .csv with the rest of the coordinates that work, re-import into ArcMap.

None of these solutions have worked. Is there anything else I can do to fix this issue?

2
  • 1
    Are the records not converting or are the points just not displaying? – danak Jul 9 '20 at 23:20
  • As @danak has commented, is it missing the entire record (look in the attribute table) or is it just the point(s) missing? If the record is in the table but the point not displayed then it's likely an issue with the coordinates. If it's the entire record then there's another issue in the row. A sample/screenshot of your csv table could be useful - you can edit your question to include. – Midavalo Jul 10 '20 at 4:19
-1

This problem is strange. Some other possible sources of error:

  1. Try to use the WGS-84 coordinate system when importing the .csv file.
  2. Try to import the .csv file using other's computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.