1

I'm attempting to use the 'Overwrite' tool inside of ArcGIS Portal, on a existing hosted Feature Layers that have Hosted datasets. I can successfully 'Add Item' from the ArcGIS Portal page, for a GeoJSON file and this creates the appropriate Feature Services and Feature Layer.

However after initial creation, if I attempt to use the 'Overwrite' feature on the Feature Layer page, it simply hangs during the process and fails to update the service with any new data.

I've performed the following tests:

  • Loaded a zipped shapefile and overwrote that - worked successfully.
  • Ensured my Feature Service was not being used by any web maps. Didn't make a difference.
  • Tried different folders as the loading location - Didn't make any difference.
  • Tried using the same source file for intial load and Overwrite. - Didn't make any difference.

I also tried a zipped file geodatabase. This actually simply failed to be created at all so I could not attempt to use the Overwrite. (I thought this was very odd as well).

So I've got:

  • Failure to load a zipped FGDB
  • Failure to Overwrite on a GeoJSON file.

Another point of interest i that I can however use ArcMap to successfully load the exact same FGDB as a service, from within ArcMap. So something appears wrong with the ArcGIS Portal page specifically.

Does anyone have any experience with this?

Update I have extended the tests to include the following scenario

  • Upload raw GeoJSON data and successfully create Feature Service
  • Exported the data to GeoJSON, from the Feature Service as a new GeoJSON dataset in ArcGIS Portal, then Downloaded the data from there. (Note - I noticed the formatting of the GeoJSON file was now different, parameters where in different order).
  • Used the downloaded as the source in the 'Overwrite' operation

This unfortunately still causes the overwrite function to hang and the changes are never reflected in the data or service. I have also checked field name casing as suggested, all original field names were lower case, and downloaded field names are lower case. The fact that im using the downloaded GeoJSON file for me confirms that this is a bug somewhere, so ill log this one with ESRI.

A link to their doco is below, was using this as a reference.

https://enterprise.arcgis.com/en/portal/10.5/use/manage-hosted-feature-layers.htm#ESRI_SECTION1_1D3A87A80E3E4CD2A71744715F1522FE

  • 1
    The update function is kind of finicky with upper/lowercase attribute names. During initial hosting in the Portal it correctly converts all the attribute fields to lowercase, but during the update process it somehow does not. Can you try converting your feature attribute fields to lowercase e.g NAME to name and try again? – Carlos Jul 20 at 8:09
  • thanks ill give that a go and let you know how it works out. – nr_aus Jul 20 at 8:46
0

I have answered my own question with regards to the File Geodatabases, ArcGIS Portal didn't like the FGDB that I was using, when I created a new one it worked, so there must have been something wrong with the initial FGDB. (I didn't create the initial FGDB, but Im not going to investigate any more on that one)

The GeoJSON file not updating still remains a mystery!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.